Hi Guys, i'm running 4.2.1 on my Iphone 3G which is jailbroken.I've tried to get Kik from the apstore however it says I need to be running 4.3.

Can anyone think of a workaround I could use? thought if I could get hold of a previous versions API then that might work but i've had no joy finding one.

Any help will really be appreciated.